climateprediction.net home page
Posts by juhoiipponen

Posts by juhoiipponen

1) Questions and Answers : Unix/Linux : "This project may not have work for your type of computer" on AMD processors and Linux x86_64 (Message 47982)
Posted 15 Jan 2014 by juhoiipponen
Post:
Now my computer 1310226 has received its first CPDN tasks, and they seem to be running great. The solution mentioned in the previous posts of mine indeed worked.

Thank you all for your great assistance! Now I'm sure I can always rely on the community in case of any problems.
-Juho
2) Questions and Answers : Unix/Linux : "This project may not have work for your type of computer" on AMD processors and Linux x86_64 (Message 47958)
Posted 9 Jan 2014 by juhoiipponen
Post:
Yes, that exact page and this one http://boinc.berkeley.edu/wiki/Installing_BOINC#64_Bit_Considerations, because they advise to install the ia32-libs package, which is no longer in repositories since 13.10. When attempting apt-get install ia32-libs the APT says that those three libraries mentioned in my previous post replace it.

This is just the new Ubuntu fix since 13.10, using ldd on the executables is probably a better choice if you have them. The problem was that CPDN refused to even send me those executables in the first place, because it knew my computer was not able to run them.

I do not know weather the solution would work on debian 7, per se, as before installing those three libraries I first enabled the i386 architecture (dpkg --add-architecture i386 && apt-get update) and then installed the ia32-libs package.
3) Questions and Answers : Unix/Linux : "This project may not have work for your type of computer" on AMD processors and Linux x86_64 (Message 47953)
Posted 8 Jan 2014 by juhoiipponen
Post:
YES!

As geophi said, I still didn't have all of the 32-bit compatibility libraries installed. I did not copy the BOINC folder from the Ubuntu 12.04 installation so I had no executables to ldd, but I decided to install the Boinc manager to my small Ubuntu 13.10 box and I thought I could perhaps copy those executables to the Debian system and try them there. Doing so I had to install again the 32-bit libraries on Ubuntu 64-bit, but now the ia32-libs package posed a difficulty: package manager said it was not available, but that the 32z1, 32ncurses5 and 32bz2-1.0 libraries needed to be installed to provide the same functionality:

sudo apt-get install lib32z1 lib32ncurses5 lib32bz2-1.0 libstdc++6 libstdc++5 freeglut3


and that did the trick on Ubuntu 13.10. I tried the same command on the Debian 7.3 computer, restarted the boinc-client, and connected to the CPDN without complaints. Now I should get WUs again.

The information about the required 32-bit libraries on the BOINC wiki page seems deprecated. Maybe someone could update it with the information that ia32-libs package doesn't exist anymore as of Ubuntu 13.10 and that the aforementioned libraries are to replace it.

Thank you all again for your quick and helpful responses!

-Juho Iipponen
4) Questions and Answers : Unix/Linux : "This project may not have work for your type of computer" on AMD processors and Linux x86_64 (Message 47948)
Posted 8 Jan 2014 by juhoiipponen
Post:
Thank you for the prompt responses, an active community has always been a big plus for CPDN!

Thanks for the tip, but all the packages mentioned on the "64-bit considerations" page in the BOINC wiki were installed (manually). It might have indeed been that I hadn't installed the ia32-libs package on the Debian 6 system I used when I first got the message, but now it is. Despite of that the message is still showing up as I am trying to attach, but I now decided to press "yes" (connect anyway) and see what happens.

CPDN has the greatest resource share of the projects now, so I should get WUs when they are released. I'll be frequently checking the the event log to see if there are any error messages from the project. I will report back to this thread weather there are problems or not.

On AMD 6300 series processors each core has their own floating point and integer units and L1 cache, so all the cores are real in a sense that they are not virtual (1 core = 1 threads, not two, as Intel has). The motherboard has four 12 core processors, so it has 48 cores in total. I have not changed the motherboard since 2011, when the computer got packages at the same rate as they were returned, so it seems unlikely that had caused the issue.
5) Questions and Answers : Unix/Linux : "This project may not have work for your type of computer" on AMD processors and Linux x86_64 (Message 47942)
Posted 7 Jan 2014 by juhoiipponen
Post:
Hi,

I am trying to connect my computer to the project yet again after some time, but as I am trying to "attach to project" using the BOINC interface, I am greeted by a familiar message "This project may not have work for your type of computer. Do you want to add it anyway? -> yes/no".

The last time I saw this was in early 2013, and I then chose "yes". After some time I was wondering why I hadn't received any work units, so I checked the event log. I unfortunately do not remember the exact message from the server, but it said something like some specific model (hadcm3n?) not being available for AMD64 Linux. After that I decided to change to other projects, none of which had the same kind of compatibility issues.

This message might be related to the Debian OS or the 3.2.0-amd64 kernel I am using, because on both occations I have seen this message I've used the Debian version 6 or 7. In December 2013 I decided to change my operating system to Ubuntu 12.04LTS. When attaching to CPDN no such messages showed up (3.8.0-generic kernel) and I was able to get WUs.

Ubuntu was not quite compatible with my system, so in late December I decided to switch back to Debian 7.3 (the previous Debian version was 6) and as said the message showed up again. I do not know weather I would receive WUs or not, but I am unwilling to find out before I get to the roots of what this incompatibility with the project might be caused of. I have searched all over the forums, and the closest thing I have had for more detailed system requirements is the FAQ's too unspecific "Recommended system requirements" page. Is there any page which might shed some more light on the issue?

Currently I am running Cosmology@home and the exact computer I am trying to connect is the 204867 (http://www.cosmologyathome.org/show_host_detail.php?hostid=204867) with BOINC version 7.0.27. It's predecessors held the project's number one host position for one and a half years through 2011 and 2012, so I am eager to connect this quite new rig that has double the horsepower.

However, I have been disappointed by the lack of work that the project has. Back in 2011 there were quite a few similar servers running Linux operating systems and holding the leading positions, but they have all gone now to another projects as can be seen from the "Top Computers" page. By seeming that you do not support the AMD and Linux 64-bit combination you are loosing hundreds of gigaflops if not teraflops worth of computing power, which I think you are currently lacking. The All project stats (http://www.allprojectstats.com/po.php?projekt=21) shows you having only 27 TFlops of computational power.

I have always considered CPDN as my main project so I would love to come back. I hope I will again see the day when CPDN can feed in new packages at the same pace as computed results are returned.

Looking forward to one day again compute to solve the greatest problem the mankind has ever faced!

Sincerely,
Juho Iipponen, BOINC@Finland




©2020 climateprediction.net