home page
Posts by klepel

Posts by klepel

1) Message boards : Number crunching : New Model Type HadAM4 (Message 62395)
Posted 3 May 2020 by klepel
Just to clarify:
a) computer is limited to "use at most = 99%"
b) climateprediction is limeted to 2 WUs with app_config
c) rest of the task is CPU: tn-grid and GPU: gpugrid
d) CPU is works at 4100 GHz - I tried to go higher (4150 GHz - around april), but then tn-grid has some random errors "SIGSEGV: segmentation violation", so I limited it again to 4100 GHz, I had some rare shut-downs since then.*
e) With this set-up RAM seems not to be an issue
f) I run some dispersion models on the computer for work sometimes, but not during this shutdown.
g) I clean computer periodicaly, so dirt should be no issue
* this explains some errors.
tn-grid works fine again, this is why I am wondering why climeteprediction does has some errors.
2) Message boards : Number crunching : New Model Type HadAM4 (Message 62389)
Posted 3 May 2020 by klepel
I have several errors: "Model crashed: READDUMP: BAD BUFFIN OF DATA". The Wus have been quite advanced.

Like this one:

I have limited the climateprediction to two concurrent WUs on this computer, so I was wondering if there is a cure.
3) Message boards : Number crunching : We're back! (Message 58362)
Posted 10 Jul 2018 by klepel
Just to report: All my completed and errored-out work has been up-loaded successfully to the server.
And even some computers have received new WUs and are crunching again.
I HAVE NOT CHANGED ANYTHING ON THESE COMPUTERS, so it seems to me, there is no need to re-attach to the project nor is it necessary to change the address of
It is more like a little patience is needed!
4) Questions and Answers : Unix/Linux : *** Running 32bit CPDN from 64bit Linux - Discussion *** (Message 55611)
Posted 30 Jan 2017 by klepel
I just wanted to report back, that I have finished successfully the following task: on Linux Lubuntu 64bit. And one more is well underway.
5) Message boards : Number crunching : New work Discussion (Message 54869)
Posted 30 Sep 2016 by klepel

Another spin for the long deadlines:
I had to change a hard disk on one of my computers. I copied the whole ProgramData/BOINC/projects folder to an USB stick before the change, changed the disc, installed BOINC, connected to the project again, downloaded some new WUs, merged the two computers with the same name on the homepage of every project, copied the old WUs from the USB to corresponding folders under projects folder.

The old WUs are visible under the computer name on the homepage, but not in the computer (BOINC manager). So if nothing happens, the will be reported until the deadline as “in process” but will never be processed. So if someone might point out how to get them recognized by BOINC on this particular computer, I would be very grateful. If this would work to transfer WUs from one computer to another, would be even better, as I have some WUs on slow computers to transfer to fasters.

Finally, I also had a crash of a hard disk, so I lost all this WUs, but as the deadline is so long, they won´t be reissued for a year.
6) Questions and Answers : Unix/Linux : *** Running 32bit CPDN from 64bit Linux - Discussion *** (Message 54619)
Posted 8 Aug 2016 by klepel
I just wanted to report back: I somehow managed to get all the necessary libs installed and the Lubuntu 64-bit computer has already crunched 6 WUs satisfactory and reported the results back.
7) Questions and Answers : Unix/Linux : *** Running 32bit CPDN from 64bit Linux - Discussion *** (Message 54424)
Posted 5 Jul 2016 by klepel
I am keep trying to run a WU to the end. So fare it runs quite well, but it does not create the intermediate zip files along with the processing of the WU.

So I am looking for a library which equals the from Ubuntu in “lubuntu” as this is the missing library the tasks which failed previously. Is it libzip4? Thanks for your help!
8) Questions and Answers : Unix/Linux : *** Running 32bit CPDN from 64bit Linux - Discussion *** (Message 54404)
Posted 29 Jun 2016 by klepel
The code for the programs belongs to the UK Met Office. I's what the researchers around the globe use. We're just being allowed to use it via a special arrangement. And the project people don't have the source code for the main modelling programs, just that for the parts that access it.

I am well aware of this. I was not insisting that shall implement a 64-bit version of UK Met Office model as I am quite aware that it is not up to to do so.

What I am looking for and I am sure many user do is that creates libraries for the main 64-bit LINUX distros and maintains these libraries, so that the 32-bit model will work out of the box or at least we do have a starting point to implement it, so I will not run 5 models for 12 days only to find out the ZIP files have not been created. This is a waste of resources which might have been used for other important projects.

We've also said more than once over the years that cpdn isn't for everyone.
So, sorry that it's not working out for you, but that's how things go.

I have supported this stance for long and I do understand it, but somehow it sounds hallow to me now. It is a reality, that the soft- and hardware is developed for 64-bit, other BOINC projects do require it, and I think I am not quite far away, when I stipulate that “POWER-USERS” as Thunder and myself are trying to migrate to LINUX to safe at least the expenses for the OS, so we might invest it in additional Hardware.

9) Questions and Answers : Unix/Linux : *** Running 32bit CPDN from 64bit Linux - Discussion *** (Message 54378)
Posted 24 Jun 2016 by klepel
Plop!! I run 5 Weather At Home 2 (wah2) v8.12 – units on Lubuntu 64-bit computer I have set-up as a BOINC cruncher, and all errored out with the same problem as Thunder has experienced.

I am just trying as it won’t work with GPUGRID and waiting for Linux Mint 18, to solve some problems with Nvidia Drivers.

However, I have not touched the computer for 12 days so would be able to finish its tasks and now there is not one zip file. Just frustrating…

Although I guess the Project-Administration won´t care: I am on the same boat as Thunder, it was my first and main project since 2004, I will run it on my MS Windows Computers, but will not insist on any Linux 64-bit cruncher I plan to set up especially for BOINC as many other BOINC projects oblige to use a Linux 64-bit to work.
10) Message boards : Number crunching : No work for Windows? (Message 52869)
Posted 14 Nov 2015 by klepel
Here the same! All hadam3p_eu fail to download.
11) Questions and Answers : Unix/Linux : *** Running 32bit CPDN from 64bit Linux - Discussion *** (Message 52339)
Posted 27 Jul 2015 by klepel
Sorry, when I misused this thread, but I could not find a better one on and I am not a user of the boinc forums, however I do since 2004. So I thought I will find some linux-geek (mint) in this forum who might easily help...

And their should be a certain interest from project people to bring down:
"hadam3prm3pm2t_eu (Linux only) Tasks ready to send 25,459 [As of 27 Jul 2015 4:49:00 UTC]" as well.

Back to my problem: I searched around for an other two hours without any success, and I think I used the Syanptic Package Manager and installed nearly all libwx packages I thought might be usefull, whithout any success. So if anybody has a solution o might be willing to help just PM me!
12) Questions and Answers : Unix/Linux : *** Running 32bit CPDN from 64bit Linux - Discussion *** (Message 52330)
Posted 25 Jul 2015 by klepel
I am not really sure, why I am doing it again...

I downloaded the Berkeley Installer from the BOINC site: Linux x64 7.2.42 and installed it on under /home/user/BOINC on a Linux Mint Cinnamon 17.1 64bits system. All of it on a USB-Stick 3.0 32GB.

Yes i did download the lib32 files.
I started with run_manager as usual nothing happens. I start run_client - it works but I am not able to attach to a project, because of my very rudimentary computer knowledge...

I do ldd boincmgr and I do get:
roland@roland-desktop ~/BOINC $ ldd boincmgr => (0xf779f000) => not found => not found => not found => not found => not found
All the rest seems installed.

So my question: where do I find these 5 libwx files? I tried with Synaptic Package Manager: No success!

Any ideas?

I would really like to help with these "hadam3prm3pm2t_eu (hadam3p global model with hadrm3p regional model with MOSES II land scheme and TRIFFID available) (currently no graphics) (Linux only)" WUs but I am not able to get BOINC running... I do have two idle computers with another OS installed, so I would be able to run with LINUX on a stick.

PS I do use the Berkeley installer as I would like to run NVIDIA GPU as well, but this never worked before, although I did not have these missing lib s either...

13) Message boards : Number crunching : UK Met Office HADAM3P (global only) with MOSES II landsurface scheme v7.03 (Message 48816)
Posted 17 Apr 2014 by klepel
14) Message boards : Number crunching : Project has no tasks available (Message 45259)
Posted 13 Nov 2012 by klepel
We all wait. Other projects benefit, in my case it is, although this projects does not give as many credits and does not run so hassle free than
15) Message boards : Number crunching : Needs more disk space (Message 42782)
Posted 17 Aug 2011 by klepel
I have received the same massage on two of my machines in a short period of time, so I assumed it was a problem with the work unites and not with the computers!

The massage is:
?Sun 14 Aug 2011 02:14:56 PM PET Message from server: UK Met Office HADAM3P Southern Africa needs 1810.77MB more disk space. You currently have 96.58 MB available and it needs 1907.35 MB.?

I solved the problem in the short term increasing the disk space under preference disk space and memory usage and afterwards I followed the instruction of Les Bayliss and delete the archives not used anymore (more than 8 GB). Everything works fine again.
16) Questions and Answers : Macintosh : Updating Mac OS X 10.3.7 (Message 9533)
Posted 18 Feb 2005 by klepel

Thanks for yours cheers up! As I learned in the meanwhile. My memory on the mainboard went down. Didn't have anything to do with Except it might have overheated, crunching 48 hours.

17) Questions and Answers : Macintosh : Updating Mac OS X 10.3.7 (Message 9152)
Posted 11 Feb 2005 by klepel
Hi there

I just bought a iBook instead of a MS Windows Notebook for work related reasons. My decision was eased knowing that I will be also able to crunch for climateprediction as I do on my MS Windows PC for months.

My first excitement cooled, as I learned, that the instalation would not be that easy as it was with the Windows Version. Nevermind I hired my local Apple supplier here in Peru to make the instalation, and was happely crunching for two days. When I was adviced to download the new version of mac OS X, I clicked on download (without thinking) and more important without exiting the climatprediction process and Terminal. During downloading I was asked to restart my computer and since then i am sitting behind a black screen with the message: "panic: We are hanging here..." and I will be without mac over the weekend, my local apple store will not have time to try to fix it until monday:(
Might be a good idea to put more emphasis to make a more fool proved version of BOINC for Mac.
18) Questions and Answers : Wish list : Hyper Threading (HT): Pause of one processor half during working hours (Message 5449)
Posted 17 Oct 2004 by klepel
Hi there,
Would it be posible to ad a feature to pause one part of the Pentium 4 HT (WU) during working hours? It is only posible to limit the numbers of procesors for the project or the working hours in general at the moment. Whereas I would like to limit the working hours only for one half of the procesor and the other half might crunching 24 hours.