climateprediction.net home page
Posts by Evans CPAH

Posts by Evans CPAH

1) Message boards : Number crunching : "No tasks sent" (Message 62411)
Posted 8 May 2020 by Evans CPAH
Post:
This is a clean install of Lubuntu 20.04. CPDN now running happily. The first job started spontaneously, at random. A second started immediately I gave it another core.

There were no similar messages in 19.04.
2) Message boards : Number crunching : "No tasks sent" (Message 62410)
Posted 7 May 2020 by Evans CPAH
Post:
The solution is obviously to post to the forum, because I now have a task running...
3) Message boards : Number crunching : "No tasks sent" (Message 62408)
Posted 7 May 2020 by Evans CPAH
Post:
Currently getting this response under Linux and BOINC 7.16.6. Status page says there are 1744 jobs available. No other relevant-looking messages.
4) Message boards : Number crunching : Ryzen Performance (Message 58648)
Posted 26 Aug 2018 by Evans CPAH
Post:
I didn't bother running CPU jobs on Bulldozer/Piledriver. The poor CPU floating point performance meant that they were better employed running GPU jobs like Einstein. I ran CPU jobs on Intel.

Switching to a Ryzen 2200G has been kind of interesting. Not only is the FP performance in the same ballpark as Intel, but it also meant in this case a healthy jump in memory throughput (to 3000 MT/s). And my hypothesis is that given acceptable FP performance, CPDN is mainly memory bound, not CPU bound. Given that it's a giant matrix that has no hope of fitting in any data cache, that wouldn't be too surprising.

For various reasons, I haven't tested this (CPDN outages, other projects running). But if it's true, it leads to two further observations: first, SMT/hyperthreading will mainly help other (non CPDN) processes, that are not memory bound. They can execute during the numerous cache misses caused by traversing a giant data structure. Second, running your CPU at full speed all the time for CPDN is a waste of power. My results seem (anecdotally) to be similar whether the 2200G is running at 3.6GHz or throttled to 2.4GHz, at a third of the power.

And yes, the 2200G has no SMT. With a lot of experience running BOINC and VMs, and BOINC in VMs, I'm not a big fan.
5) Questions and Answers : Windows : Visual Fortran run-time syntax error (Message 2757)
Posted 2 Sep 2004 by Evans CPAH
Post:
Come on, guys.

Win32 4.05

forrtl: severe (17): syntax error in NAMELIST input, unit 57, file

This is the first cp work unit I\'ve (tried to) run. BOINC has not handled this error, thinks the wu is running.

Ant





©2022 climateprediction.net