climateprediction.net home page
7.16.3 on Ermine

7.16.3 on Ermine

Questions and Answers : Unix/Linux : 7.16.3 on Ermine
Message board moderation

To post messages, you must log in.

AuthorMessage
Profile Dave Jackson
Volunteer moderator

Send message
Joined: 15 May 09
Posts: 2792
Credit: 3,659,580
RAC: 11,331
Message 61351 - Posted: 23 Oct 2019, 7:49:57 UTC

When I went to do a File>Exit I found that the version of 7.16.3 that I got from the repository only has the options
New Boinc Manager Window
Select Computer
Close Window.

Shut down Connected Client and Exit Boinc are both missing.

I have posted about this on the Boinc forums and Richard has responded with the rational for this change which he does not agree with.
https://boinc.berkeley.edu/forum_thread.php?id=13183
ID: 61351 · Report as offensive     Reply Quote
Profile geophi
Volunteer moderator

Send message
Joined: 7 Aug 04
Posts: 1942
Credit: 41,861,826
RAC: 19,854
Message 61352 - Posted: 23 Oct 2019, 12:26:57 UTC - in response to Message 61351.  

This is idiotic. While I understand the reasoning from a corporate point of view, how many of the Linux boinc users are in that category? I certainly don't know but this is going to make home users lives very difficult unless you really do just crunch all the time. Couldn't they have two versions in the repository, one for the corporate minions in the sweatshops, and one for people who want and need some control over their computers, what software is installed, and how it is utilized. I don't know how much work it would take to keep up two versions in a repository with this difference in functionality, but if something like that doesn't happen. I won't be upgrading in Linux past whichever version still supports a user-controllable boinc.
ID: 61352 · Report as offensive     Reply Quote
Profile Dave Jackson
Volunteer moderator

Send message
Joined: 15 May 09
Posts: 2792
Credit: 3,659,580
RAC: 11,331
Message 61353 - Posted: 23 Oct 2019, 12:46:03 UTC - in response to Message 61352.  

There is now a link in the BOINC forum thread to a version you can download from github to roll your own without those bits of functionality removed. Having found the dependencies needed again, I am now doing that.
ID: 61353 · Report as offensive     Reply Quote
WB8ILI

Send message
Joined: 1 Sep 04
Posts: 140
Credit: 55,519,048
RAC: 14,801
Message 61354 - Posted: 23 Oct 2019, 13:43:32 UTC - in response to Message 61353.  

Where exactly is the "BOINC forum thread"?
ID: 61354 · Report as offensive     Reply Quote
Les Bayliss
Volunteer moderator

Send message
Joined: 5 Sep 04
Posts: 7262
Credit: 23,235,750
RAC: 5,211
Message 61355 - Posted: 23 Oct 2019, 13:46:30 UTC

Try the link which is the bottom line in Dave's first post. :)
ID: 61355 · Report as offensive     Reply Quote
Profile Dave Jackson
Volunteer moderator

Send message
Joined: 15 May 09
Posts: 2792
Credit: 3,659,580
RAC: 11,331
Message 61366 - Posted: 24 Oct 2019, 5:59:46 UTC
Last modified: 24 Oct 2019, 9:18:37 UTC

If anyone does want to roll their own these are the dependencies I had to install to get ./configure to finish.

Sudo apt-get install m4 autoconf libtool libssl-dev curl libcurl4-openssl-dev libwxgtk3.0-dev libnotify-dev sqlite3-dev libgtk-3-dev


The last two didn't show up as errors with ./configure but did cause make to fall over. When I did things on 19.04 things were a lot simpler because a number of these libraries were already installed. Don't be alarmed by the brightly coloured warnings flashing across your terminal while running make!

Edit: getting a fatal error at the make stage. I have asked what might be causing this on the BOINC boards.

Edit2:Rookie error
sudo apt-get install gtk2+-dev
enabled the make stage to run.

Edit3: If I am going to continue rolling my own BOINC I need either
1. More patience or
2. A faster computer!
ID: 61366 · Report as offensive     Reply Quote

Questions and Answers : Unix/Linux : 7.16.3 on Ermine

©2020 climateprediction.net