climateprediction.net home page
Server upgrade issues

Server upgrade issues

Message boards : Number crunching : Server upgrade issues
Message board moderation

To post messages, you must log in.

Previous · 1 · 2 · 3 · Next

AuthorMessage
Richard Haselgrove

Send message
Joined: 1 Jan 07
Posts: 440
Credit: 15,158,742
RAC: 392
Message 39855 - Posted: 4 Jun 2010, 7:25:52 UTC - in response to Message 39853.  

I uploaded & reported last night, just before the credit run and have been and still am at Completed, can't validate. Now that model also sits at "Too many errors (may have bug) Too many total results" while all the ones that were finished before were finished correctly.
We've always had workunits which for one reason or another exceed the BOINC "Too many ...." limits (usually because the limits have been set inappropriately low for the initial replication required). But at CPDN, credit isn't dependent on validation: the trickle process running overnight awards credits quite independently of the standard BOINC daemons.

Or doesn't, as the case may be. Looks like Milo has another glitch to chase down in due course.
ID: 39855 · Report as offensive     Reply Quote
Profile Milo Thurston
Volunteer moderator
Volunteer developer

Send message
Joined: 2 Mar 06
Posts: 253
Credit: 363,646
RAC: 0
Message 39856 - Posted: 4 Jun 2010, 7:56:59 UTC - in response to Message 39848.  

show_user.php generates the following pair of errors:

[quote]Warning: Attempt to assign property of non-object in /var/www/boinc/projects/cpdnboinc/html/user/show_user.php on line 81


Now "fixed".


...but the show_user.php code suggests that the data caching is failing and every subsequent attempt to access the page for the same user ... picks up uninitialised data from the cache and generates the error


I'm not sure yet of why but that is under investigation. Meanwhile a hack is in place to work around this particular example.

ID: 39856 · Report as offensive     Reply Quote
Profile Milo Thurston
Volunteer moderator
Volunteer developer

Send message
Joined: 2 Mar 06
Posts: 253
Credit: 363,646
RAC: 0
Message 39857 - Posted: 4 Jun 2010, 8:16:00 UTC - in response to Message 39851.  
Last modified: 4 Jun 2010, 8:25:13 UTC

I'm get this message when I try to post an Active link to my computer:
Your post has been flagged as spam by the Akismet anti-spam system. Please modify your text and try again.


It should now be disabled.


also I find that the Buttons for: "Use BBCode tags to format your text" don't seem to work. I have to manualy put in the BBCode tags.
I'm using IE8 OS WXPSP3


I'll investigate this one - probably a javascript problem.

Edit: Now working.
ID: 39857 · Report as offensive     Reply Quote
transient

Send message
Joined: 3 Oct 06
Posts: 43
Credit: 8,017,057
RAC: 0
Message 39858 - Posted: 4 Jun 2010, 9:03:28 UTC

I saw this message in my log. Is this also related to the server upgrade?

6/4/2010 10:56:45 AM climateprediction.net You used the wrong URL for this project
6/4/2010 10:56:45 AM climateprediction.net The correct URL is http://climateapps2.oucs.ox.ac.uk/cpdnboinc/
ID: 39858 · Report as offensive     Reply Quote
Profile Milo Thurston
Volunteer moderator
Volunteer developer

Send message
Joined: 2 Mar 06
Posts: 253
Credit: 363,646
RAC: 0
Message 39859 - Posted: 4 Jun 2010, 9:08:18 UTC - in response to Message 39858.  

I saw this message in my log. Is this also related to the server upgrade?

6/4/2010 10:56:45 AM climateprediction.net You used the wrong URL for this project
6/4/2010 10:56:45 AM climateprediction.net The correct URL is http://climateapps2.oucs.ox.ac.uk/cpdnboinc/


Yes, but it should be fixed now.
Because we have always had a separate site for the science-related information it sometimes causes problems with URLs - I've had one other complaint this morning about a different, but related error.
ID: 39859 · Report as offensive     Reply Quote
old_user3

Send message
Joined: 5 Aug 04
Posts: 173
Credit: 1,843,046
RAC: 0
Message 39860 - Posted: 4 Jun 2010, 10:35:09 UTC - in response to Message 39855.  

I uploaded & reported last night, just before the credit run and have been and still am at Completed, can't validate. Now that model also sits at "Too many errors (may have bug) Too many total results" while all the ones that were finished before were finished correctly.
We've always had workunits which for one reason or another exceed the BOINC "Too many ...." limits (usually because the limits have been set inappropriately low for the initial replication required). But at CPDN, credit isn't dependent on validation: the trickle process running overnight awards credits quite independently of the standard BOINC daemons.

Or doesn't, as the case may be. Looks like Milo has another glitch to chase down in due course.



the problem with this was that the max_error was set too low.
I've increased it. sorry
ID: 39860 · Report as offensive     Reply Quote
Profile Milo Thurston
Volunteer moderator
Volunteer developer

Send message
Joined: 2 Mar 06
Posts: 253
Credit: 363,646
RAC: 0
Message 39861 - Posted: 4 Jun 2010, 10:58:55 UTC

The pending credit display problem should now be fixed as well.
ID: 39861 · Report as offensive     Reply Quote
Profile JIM

Send message
Joined: 31 Dec 07
Posts: 1147
Credit: 21,159,011
RAC: 0
Message 39862 - Posted: 4 Jun 2010, 14:13:10 UTC - in response to Message 39854.  
Last modified: 4 Jun 2010, 14:15:24 UTC

Dear Ageless:

Thanks for the info. As long as I know it’s a server problem I will just wait it out.
ID: 39862 · Report as offensive     Reply Quote
Profile astroWX
Volunteer moderator

Send message
Joined: 5 Aug 04
Posts: 1496
Credit: 95,434,672
RAC: 0
Message 39863 - Posted: 4 Jun 2010, 19:59:29 UTC
Last modified: 4 Jun 2010, 20:03:07 UTC

FAMOUS v.6.10 downloads were distressingly slow yesterday and today. Different machines and different Windows OS involved. Could this be related to the changes?
Edit: Slab upload speeds were normal.
"We have met the enemy and he is us." -- Pogo
Greetings from coastal Washington state, the scenic US Pacific Northwest.
ID: 39863 · Report as offensive     Reply Quote
Jord
Avatar

Send message
Joined: 5 Aug 04
Posts: 250
Credit: 93,274
RAC: 0
Message 39868 - Posted: 5 Jun 2010, 8:53:03 UTC - in response to Message 39863.  

Edit: Slab upload speeds were normal.

I saw the 28MB file of my new Hadam3p come in at a blistering 78KB/sec... not fast in my opinion. :-)
Jord.
ID: 39868 · Report as offensive     Reply Quote
old_user596405

Send message
Joined: 4 Oct 09
Posts: 73
Credit: 7,242,427
RAC: 0
Message 39869 - Posted: 5 Jun 2010, 17:29:18 UTC
Last modified: 5 Jun 2010, 17:30:14 UTC

Can no longer log out since the upgrade.

The "Logged out" page is shown as usual after taking the "Log out" option.
Clicking on "Your account" in left panel as the normal way of logging back in,
returns to (already) logged in "Your account" page!

Wanted to switch to an old dormant account to check if everything still there
- e.g. should have BBC and Beta totals in the "Credits from Affiliated..." section.

Tried from 3 machines. Cannot think of any other way to get to that account. :(

iansm
ID: 39869 · Report as offensive     Reply Quote
Profile Thyme Lawn
Volunteer moderator

Send message
Joined: 5 Aug 04
Posts: 1279
Credit: 15,786,297
RAC: 0
Message 39870 - Posted: 5 Jun 2010, 19:09:48 UTC - in response to Message 39869.  

You'll be automatically logged on if you have an "auth" cookie for climateapps2.oucs.ox.ac.uk. I just deleted that on my system and I was forced to log in again.
"The ultimate test of a moral society is the kind of world that it leaves to its children." - Dietrich Bonhoeffer
ID: 39870 · Report as offensive     Reply Quote
transient

Send message
Joined: 3 Oct 06
Posts: 43
Credit: 8,017,057
RAC: 0
Message 39871 - Posted: 6 Jun 2010, 9:30:02 UTC

On the overview page for tasks per computer, I do not see the credits for tasks which have actually trickled. Only the credits for completed tasks are shown. Is that intentional? Looking in detail the task shows credits claimed and granted.
ID: 39871 · Report as offensive     Reply Quote
old_user596405

Send message
Joined: 4 Oct 09
Posts: 73
Credit: 7,242,427
RAC: 0
Message 39872 - Posted: 6 Jun 2010, 10:09:38 UTC - in response to Message 39870.  

You'll be automatically logged on if you have an "auth" cookie for climateapps2.oucs.ox.ac.uk. I just deleted that on my system and I was forced to log in again.


Thanks Thyme. Actually did try deleting that cookie in a Win 7 system when the problem arose - but no joy.

Revisited the issue again.

Deleted and recreated the cookie in an XP system so was able to resume logging out and in ok.

Still no good in Win 7 until I deleted all cookies including "index.dat" in the
"...\appdata\roaming\microsoft\windows\cookies\low" folder (backed up of course).

Then it worked so presumably index.dat had to go as well.

Have had to delete a cookie file in other sites when similar issues occurred. Like the file had got sort of corrupted.

ID: 39872 · Report as offensive     Reply Quote
Profile mo.v
Volunteer moderator
Avatar

Send message
Joined: 29 Sep 04
Posts: 2363
Credit: 14,611,758
RAC: 0
Message 39893 - Posted: 8 Jun 2010, 18:53:31 UTC
Last modified: 9 Jun 2010, 2:20:50 UTC

I think I've found at least one error in the German Boinc translation.

I will move the posts about this German translation to a new thread so I can post links to the translation pages and we can discuss them in detail. I don't want a detailed discussion here; when Milo returns tomorrow (Wednesday) he needs to see a list of things he needs to do, not a discussion.

When we are sure in the discussion thread what everything means in both English and German I hope we will be able to suggest what Milo needs to do and on the Boinc_loc email list I will be able to ask a volunteer German translator to change the necessary items.

The new thread is here.
Cpdn news
ID: 39893 · Report as offensive     Reply Quote
Profile mo.v
Volunteer moderator
Avatar

Send message
Joined: 29 Sep 04
Posts: 2363
Credit: 14,611,758
RAC: 0
Message 39895 - Posted: 9 Jun 2010, 2:23:29 UTC
Last modified: 8 Jul 2010, 23:27:25 UTC

It now seems to be impossible to delete our own posts by editing them, deleting all the content and reposting them.
Cpdn news
ID: 39895 · Report as offensive     Reply Quote
Profile mo.v
Volunteer moderator
Avatar

Send message
Joined: 29 Sep 04
Posts: 2363
Credit: 14,611,758
RAC: 0
Message 39902 - Posted: 10 Jun 2010, 0:32:43 UTC
Last modified: 10 Jun 2010, 1:27:55 UTC

Milo, there are three errors in the German translation of members' account preferences. One of these is so erroneous that German-speaking members can now wrongly edit their preferences and then be unable to fetch new work. This has already happened.

The same thing has happened at Einstein. Bernd has edited the translation file there. I'm going to list the three edits you need to make in the German Boinc generic translation file. You'll need to delete the current German translations for these items and replace them with what Bernd says. I have put the current German errors that need to be deleted in red:

-------------------------------------------------------------------

Computing preferences, item #6

English says:

Suspend work if CPU usage is above
0 means no restriction
Enforced by version 6.10.30+

Delete: Ausführung auf Grafikkarte anhalten wenn der Computer benutzt wird?
Unterstützt ab Version 6.7 aufwärts


Bernd says:

Ausführung anhalten wenn die CPU Last höher als
ist 0 = keine Einschränkung
Unterstützt ab Version 6.10.30 aufwärts

Computing preferences, item # 11

English says:

On multiprocessors, use at most
Enforced by version 6.1+

German error is: Ausführung auf Grafikkarte anhalten wenn der Computer benutzt wird?
Unterstützt ab Version 6.7 aufwärts


Bernd just deleted this German translation but could you put the following, translated by Ananas:

Auf Mehrprozessorsystemen maximal verwenden : 100% der Prozessoren
Unterstützt ab Version 6.1 aufwärts

Project preferences, item #2

English says:

Use CPU
Enforced by version 6.10+

German error is: Ausführung auf Grafikkarte anhalten wenn der Computer benutzt wird?
Unterstützt ab Version 6.7 aufwärts


Bernd says:

Ausführung auf CPU?
Unterstützt ab Version 6.10 aufwärts

-----------------------------------------------------------------------

We don't usually ask you to improve the translations but for German-speaking members this can be a showstopper.
Cpdn news
ID: 39902 · Report as offensive     Reply Quote
Profile Milo Thurston
Volunteer moderator
Volunteer developer

Send message
Joined: 2 Mar 06
Posts: 253
Credit: 363,646
RAC: 0
Message 39913 - Posted: 10 Jun 2010, 13:35:26 UTC

Thanks for tracking that down, Mo.
We're having a bit of trouble with some of our development hardware at the moment but will deal with any outstanding issues ASAP.
ID: 39913 · Report as offensive     Reply Quote
Profile scottishwebcamslive.com
Avatar

Send message
Joined: 21 Jun 06
Posts: 26
Credit: 8,397,236
RAC: 0
Message 39935 - Posted: 14 Jun 2010, 4:59:31 UTC

This is part of another thread i started that was informed would be better placed here

Something strange has happened to the number of posts that this forum says youve made as i've been a member since 2006 and Scotland team Founder since then and have been in here posting way more than that !
my question is has the forum database lost thousands of posts or is this just a numerical error by the new forum software ?
i notice my signature doesnt show up now either !

best regards
Ian
ID: 39935 · Report as offensive     Reply Quote
Profile Iain Inglis
Volunteer moderator

Send message
Joined: 16 Jan 10
Posts: 1058
Credit: 6,463,915
RAC: 0
Message 40008 - Posted: 24 Jun 2010, 13:40:17 UTC
Last modified: 24 Jun 2010, 14:48:02 UTC

A few oddities that I've noticed after returning from hols ...

1. The 'search for user' facility doesn't behave very predictably. (Was it there before? Can't remember.) Searching for names beginning with 'Milo' brings up a plausibly complete list. Searching for 'Iain', however, does not. Perhaps the result page needs to say 'and others ...' or it should be paginated. Trying to reduce the list size by selecting only those with a profile (or a team) produces the incorrect report 'No users match your search criteria.'

This might be a half-baked BOINC facility rather than an upgrade problem.

2. The 'project equivalences' on the account page seem a bit odd: the version of me I'm posting from now has done one slab model. This is apparently equivalent to 1.05 'HadSM3 Complete (45-year) Runs' and 47.26 HadSM3 Model-Years. Perhaps these numbers relate to some other version of HADSM3, but I expected 1.00 and 72.

3. The BOINC nomenclature has made a step towards comprehensibility by swapping 'host' and 'computer', and 'result' and 'task'. Much better. However, some of the CPDN tailoring has been left behind in the upgrade. So, the task page (e.g. here) now has both terms in use - which will inevitably confuse someone.

Since the 'Host ID', 'Result ID' and 'Result Name' columns are redundant, they should perhaps be deleted rather than corrected. (Ockham's Razor, 3NF - less tailoring!)

[Edit]4. There seems to be an encoding issue, presumably in the database, so that some characters are rendered in the browser escaped. New posts seem fine.

Here's a dash test ...

Futile—the Winds—
To a Heart in port—
Done with the Compass—
Done with the Chart!


... let's see how that progresses.
ID: 40008 · Report as offensive     Reply Quote
Previous · 1 · 2 · 3 · Next

Message boards : Number crunching : Server upgrade issues

©2022 climateprediction.net