climateprediction.net home page
Fortran runtime dynamic library compatibility problem

Fortran runtime dynamic library compatibility problem

Questions and Answers : Macintosh : Fortran runtime dynamic library compatibility problem
Message board moderation

To post messages, you must log in.

AuthorMessage
Profile Thyme Lawn
Volunteer moderator

Send message
Joined: 5 Aug 04
Posts: 1278
Credit: 15,779,438
RAC: 0
Message 37001 - Posted: 27 May 2009, 18:16:08 UTC
Last modified: 27 May 2009, 20:09:25 UTC

If you are running CPDN on a Mac you might find that tasks from some version 6 applications are crashing immediately.

The HADCM3 and HADAM3P applications had to be compiled with the latest Fortran compiler, all other applications were compiled with the previous version. A Fortran dynamic library has to be re-distributed with Mac applications, with a different version being required for the 2 compilers. But the files have the same name, which creates an unavoidable conflict:

  • if the first CPDN task you download is not HADCM3 or HADAM3P you'll only be able to run tasks for the HADSM3, HADAM3 and HADSM3 Mid-Holocene applications.

  • if the first CPDN task you download is HADCM3 or HADAM3P it's possible that you'll only be able to run those applications.


Tolu is working on resolving this, but in the meantime your best option is to modify your project preferences to exclude the applications you are having problems with.


"The ultimate test of a moral society is the kind of world that it leaves to its children." - Dietrich Bonhoeffer
ID: 37001 · Report as offensive     Reply Quote

Questions and Answers : Macintosh : Fortran runtime dynamic library compatibility problem

©2020 climateprediction.net