climateprediction.net home page
BOINC Not Installing in OpenSuse 10.3 - libc.so problem

BOINC Not Installing in OpenSuse 10.3 - libc.so problem

Questions and Answers : Unix/Linux : BOINC Not Installing in OpenSuse 10.3 - libc.so problem
Message board moderation

To post messages, you must log in.

AuthorMessage
Profile old_user27607

Send message
Joined: 28 Oct 04
Posts: 64
Credit: 34,444,555
RAC: 0
Message 31890 - Posted: 26 Dec 2007, 18:36:57 UTC

I have the latest Linux BOINC DL.
Here is the exit stack:
Skin Manager: Failed to load \'w\' background color. Using default.
connect: Operation now in progress
*** glibc detected *** ./boincmgr: free(): invalid pointer: 0x0880b9c0 ***
======= Backtrace: =========
/lib/libc.so.6[0xf78a24b6]
/lib/libc.so.6(cfree+0x89)[0xf78a4179]
/usr/lib/libglib-2.0.so.0(g_free+0x31)[0xf79fcd61]
./boincmgr[0x81ac9b4]
./boincmgr[0x81acd77]
./boincmgr[0x80e2968]
./boincmgr[0x80e2ffd]
./boincmgr[0x80e95fd]
./boincmgr[0x810a70d]
./boincmgr[0x82c4c00]
./boincmgr[0x82c4e46]
./boincmgr[0x82c57f4]
./boincmgr[0x82c5657]
./boincmgr[0x826bca5]
./boincmgr[0x8172d53]
/usr/lib/libglib-2.0.so.0[0xf79f3a31]
/usr/lib/libglib-2.0.so.0(g_main_context_dispatch+0x176)[0xf79f55d6]
/usr/lib/libglib-2.0.so.0[0xf79f8972]
/usr/lib/libglib-2.0.so.0(g_main_loop_run+0x1e7)[0xf79f8d57]
/usr/lib/libgtk-x11-2.0.so.0(gtk_main+0xb4)[0xf7ce8244]
./boincmgr[0x821bab5]
./boincmgr[0x81c88b5]
./boincmgr[0x82908e4]
./boincmgr[0x80732e4]
/lib/libc.so.6(__libc_start_main+0xe0)[0xf7851fe0]
./boincmgr[0x805a2f1]
======= Memory map: ========
08048000-085c5000 r-xp 00000000 08:03 12124163 /y1/BOINC/boincmgr
085c5000-085e6000 rw-p 0057d000 08:03 12124163 /y1/BOINC/boincmgr
085e6000-08823000 rw-p 085e6000 00:00 0 [heap]
f6f00000-f6f21000 rw-p f6f00000 00:00 0
f6f21000-f7000000 ---p f6f21000 00:00 0
f70dc000-f7103000 rw-p f70dc000 00:00 0
f7111000-f7130000 r--p 00000000 08:01 6230134 /usr/share/fonts/truetype/cumbwr__.ttf
f7130000-f715a000 r--p 00000000 08:01 6230117 /usr/share/fonts/truetype/albwb.ttf
f715a000-f715e000 r-xp 00000000 08:01 6459470 /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so
f715e000-f7160000 rw-p 00003000 08:01 6459470 /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so
f7160000-f718a000 r--p 00000000 08:01 6230116 /usr/share/fonts/truetype/albw.ttf
f718a000-f718c000 r-xp 00000000 08:01 6443404 /usr/lib/pango/1.6.0/modules/pango-basic-fc.so
f718c000-f718e000 rw-p 00001000 08:01 6443404 /usr/lib/pango/1.6.0/modules/pango-basic-fc.so
f718e000-f7191000 rw-s 00000000 00:09 2818052 /SYSV00000000 (deleted)
f7191000-f7197000 r-xp 00000000 08:01 6459462 /usr/lib/gtk-2.0/2.10.0/immodules/im-xim.so
f7197000-f7199000 rw-p 00005000 08:01 6459462 /usr/lib/gtk-2.0/2.10.0/immodules/im-xim.so
f7199000-f71ce000 r--s 00000000 08:01 1604003 /var/run/nscd/db1HPRJi (deleted)
f71ce000-f71fe000 rw-s 00000000 00:09 2785283 /SYSV00000000 (deleted)
f71fe000-f725e000 rw-s 00000000 00:09 2752514 /SYSV00000000 (deleted)
f725e000-f7264000 r-xp 00000000 08:01 6459477 /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-xpm.so
f7264000-f7266000 rw-p 00005000 08:01 6459477 /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-xpm.so
f7266000-f726d000 r--s 00000000 08:01 1603862 /var/cache/fontconfig/77e41c5059666d75f92e318d4be8c21e-x86.cache-2
f726d000-f7270000 r--s 00000000 08:01 1603872 /var/cache/fontconfig/50ca609b9725bb1ed854a509bd9b538e-x86.cache-2
f7270000-f7271000 r--s 00000000 08:01 1603870 /var/cache/fontconfig/17eac1165263be9f8c818b6f419cf6e6-x86.cache-2
f7271000-f7273000 r--s 00000000 08:01 1603868 /var/cache/fontconfig/d458be102e54cf534d1eef0dcbb02d07-x86.cache-2
f7273000-f7296000 r--s 00000000 08:01 1603866 /var/cache/fontconfig/8d4af663993b81a124ee82e610bb31f9-x86.cache-2
f7296000-f72a7000 r--s 00000000 08:01 1603867 /var/cache/fontconfig/7ef2298fde41cc6eeb7af42e48b7d293-x86.cache-2
f72a7000-f72ed000 r--s 00000000 08:01 1603859 /var/cache/fontconfig/17090aa38d5c6f09fb8c5c354938f1d7-x86.cache-2
f72ed000-f7333000 r--s 00000000 08:01 1603858SIGABRT: abort called
Stack trace (32 frames):
./boincmgr[0x812e1c7]
[0xffffe500]
[0xffffe405]
/lib/libc.so.6(gsignal+0x55)[0xf78658f5]
/lib/libc.so.6(abort+0x101)[0xf78671e1]
/lib/libc.so.6[0xf789c80c]
/lib/libc.so.6[0xf78a24b6]
/lib/libc.so.6(cfree+0x89)[0xf78a4179]
/usr/lib/libglib-2.0.so.0(g_free+0x31)[0xf79fcd61]
./boincmgr[0x81ac9b4]
./boincmgr[0x81acd77]
./boincmgr[0x80e2968]
./boincmgr[0x80e2ffd]
./boincmgr[0x80e95fd]
./boincmgr[0x810a70d]
./boincmgr[0x82c4c00]
./boincmgr[0x82c4e46]
./boincmgr[0x82c57f4]
./boincmgr[0x82c5657]
./boincmgr[0x826bca5]
./boincmgr[0x8172d53]
/usr/lib/libglib-2.0.so.0[0xf79f3a31]
/usr/lib/libglib-2.0.so.0(g_main_context_dispatch+0x176)[0xf79f55d6]
/usr/lib/libglib-2.0.so.0[0xf79f8972]
/usr/lib/libglib-2.0.so.0(g_main_loop_run+0x1e7)[0xf79f8d57]
/usr/lib/libgtk-x11-2.0.so.0(gtk_main+0xb4)[0xf7ce8244]
./boincmgr[0x821bab5]
./boincmgr[0x81c88b5]
./boincmgr[0x82908e4]
./boincmgr[0x80732e4]
/lib/libc.so.6(__libc_start_main+0xe0)[0xf7851fe0]
./boincmgr[0x805a2f1]

Exiting...

ID: 31890 · Report as offensive     Reply Quote
Profile MikeMarsUK
Volunteer moderator
Avatar

Send message
Joined: 13 Jan 06
Posts: 1498
Credit: 15,613,038
RAC: 0
Message 31891 - Posted: 26 Dec 2007, 23:52:41 UTC


I didn\'t have any problems when installing in 10.3. But a few questions come to mind:

* Is this this 32-bit 10.3 or the 64-bit? If 64-bit, did you install 32-bit package support (IA32?)

* Which version of Boinc are you trying to install, was this the Ubuntu-only version 5.10.28, or one which can run on any distribution (5.8.16 or 5.10.21)? 32-bit or 64-bit?

I'm a volunteer and my views are my own.
News and Announcements and FAQ
ID: 31891 · Report as offensive     Reply Quote
Profile old_user27607

Send message
Joined: 28 Oct 04
Posts: 64
Credit: 34,444,555
RAC: 0
Message 31892 - Posted: 27 Dec 2007, 1:07:15 UTC - in response to Message 31891.  


I didn\'t have any problems when installing in 10.3. But a few questions come to mind:

* Is this this 32-bit 10.3 or the 64-bit? If 64-bit, did you install 32-bit package support (IA32?)

* Which version of Boinc are you trying to install, was this the Ubuntu-only version 5.10.28, or one which can run on any distribution (5.8.16 or 5.10.21)? 32-bit or 64-bit?


I thought the 32 bit support was default, but I\'ll check. And I ran 5.8.16. My install is 64 bit OS.

Thanks for the response,
BillN
ID: 31892 · Report as offensive     Reply Quote
Profile old_user27607

Send message
Joined: 28 Oct 04
Posts: 64
Credit: 34,444,555
RAC: 0
Message 31893 - Posted: 27 Dec 2007, 1:31:56 UTC - in response to Message 31892.  


I didn\'t have any problems when installing in 10.3. But a few questions come to mind:

* Is this this 32-bit 10.3 or the 64-bit? If 64-bit, did you install 32-bit package support (IA32?)

* Which version of Boinc are you trying to install, was this the Ubuntu-only version 5.10.28, or one which can run on any distribution (5.8.16 or 5.10.21)? 32-bit or 64-bit?


I thought the 32 bit support was default, but I\'ll check. And I ran 5.8.16. My install is 64 bit OS.

Thanks for the response,
BillN

I checked the system libraries - all of the 32 bit versions are checked, along with the standard 64 bit ones. SO the 32 bit stuff is installed.

Any more clues?
Thanks.
ID: 31893 · Report as offensive     Reply Quote
Profile MikeMarsUK
Volunteer moderator
Avatar

Send message
Joined: 13 Jan 06
Posts: 1498
Credit: 15,613,038
RAC: 0
Message 31898 - Posted: 27 Dec 2007, 11:22:19 UTC


In that case, I\'m out of ideas... but you could try installing 5.10.21 (it\'s not on download_all.php, but somewhere around there is a link to an FTP site at berkeley which has everything).

The Ubuntu version can be made to work on openSUSE, but involves downloading a number of extra libraries (there is a recent thread at http://boinc.berkeley.edu/dev/ discussing how)
I'm a volunteer and my views are my own.
News and Announcements and FAQ
ID: 31898 · Report as offensive     Reply Quote
Les Bayliss
Volunteer moderator

Send message
Joined: 5 Sep 04
Posts: 7503
Credit: 23,674,684
RAC: 3,244
Message 31899 - Posted: 27 Dec 2007, 11:44:58 UTC


\"Everything\" here.

But it only goes to 5.10.19

ID: 31899 · Report as offensive     Reply Quote
Profile MikeMarsUK
Volunteer moderator
Avatar

Send message
Joined: 13 Jan 06
Posts: 1498
Credit: 15,613,038
RAC: 0
Message 31900 - Posted: 27 Dec 2007, 13:50:51 UTC


If all else fails I could upload my copy of Linux 5.10.21, although note that this was the 32-bit version.


I'm a volunteer and my views are my own.
News and Announcements and FAQ
ID: 31900 · Report as offensive     Reply Quote
Profile MikeMarsUK
Volunteer moderator
Avatar

Send message
Joined: 13 Jan 06
Posts: 1498
Credit: 15,613,038
RAC: 0
Message 31901 - Posted: 27 Dec 2007, 16:28:29 UTC

Ageless has provided a download for 5.10.21, both 32-bit and 64-bit:

http://boinc.berkeley.edu/dev/forum_thread.php?id=2370&nowrap=true#14540

I'm a volunteer and my views are my own.
News and Announcements and FAQ
ID: 31901 · Report as offensive     Reply Quote
Profile old_user27607

Send message
Joined: 28 Oct 04
Posts: 64
Credit: 34,444,555
RAC: 0
Message 31912 - Posted: 29 Dec 2007, 18:45:40 UTC - in response to Message 31901.  

Ageless has provided a download for 5.10.21, both 32-bit and 64-bit:

http://boinc.berkeley.edu/dev/forum_thread.php?id=2370&nowrap=true#14540


Large thanks for the pointer to Ageless, whose skill has not withered. :-}

BillN
ID: 31912 · Report as offensive     Reply Quote
Profile old_user27607

Send message
Joined: 28 Oct 04
Posts: 64
Credit: 34,444,555
RAC: 0
Message 31913 - Posted: 29 Dec 2007, 20:39:24 UTC - in response to Message 31912.  

Ageless has provided a download for 5.10.21, both 32-bit and 64-bit:

http://boinc.berkeley.edu/dev/forum_thread.php?id=2370&nowrap=true#14540


Large thanks for the pointer to Ageless, whose skill has not withered. :-}

BillN


I can finally confirm that 5.10.21 does run under Suse 10.3 and processes work units properly.

Separately, I had to revise my selected WU because of none being available in my selection. But I also enabled the large (1.5GB required) WU which can now run in a few of my 2GB+ systems.

All\'s well that ends.
BillN
ID: 31913 · Report as offensive     Reply Quote
Profile old_user196966

Send message
Joined: 26 Aug 06
Posts: 9
Credit: 127,671
RAC: 0
Message 34222 - Posted: 5 Jul 2008, 14:49:30 UTC

You are getting GLIB errors. Most likely glib is not current
or incompatible with what BOINC is using.
Did you try to do a YAST update recently?
Never mind the distro, the libs may be old.
ID: 34222 · Report as offensive     Reply Quote

Questions and Answers : Unix/Linux : BOINC Not Installing in OpenSuse 10.3 - libc.so problem

©2021 climateprediction.net