climateprediction.net home page
GLIBCXX_3.4.15

GLIBCXX_3.4.15

Questions and Answers : Unix/Linux : GLIBCXX_3.4.15
Message board moderation

To post messages, you must log in.

AuthorMessage
DJStarfox

Send message
Joined: 27 Jan 07
Posts: 287
Credit: 1,985,598
RAC: 6
Message 51446 - Posted: 22 Feb 2015, 13:58:30 UTC

On all the recent hadCM3s models, two trickles complete but then the model crashes with the following error:

dlopen error: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /var/lib/boinc/projects/climateprediction.net/hadcm3s_se_7.24_i686-pc-linux-gnu.so)

From this result:
http://climateapps2.oerc.ox.ac.uk/cpdnboinc/result.php?resultid=17960984

Did the software requirements change? What library am I missing? CentOS 6.6, kernel 2.6.32 x86_64.
ID: 51446 · Report as offensive     Reply Quote
Les Bayliss
Volunteer moderator

Send message
Joined: 5 Sep 04
Posts: 6950
Credit: 20,843,205
RAC: 0
Message 51447 - Posted: 23 Feb 2015, 2:38:25 UTC - in response to Message 51446.  

Hello DJ

I last ran these a month ago, and they worked then.
I'm running Mint, which derives from Ubuntu, so slightly different situation.

I've sent an email asking about it.

ID: 51447 · Report as offensive     Reply Quote
Les Bayliss
Volunteer moderator

Send message
Joined: 5 Sep 04
Posts: 6950
Credit: 20,843,205
RAC: 0
Message 51478 - Posted: 26 Feb 2015, 21:04:26 UTC

OK, I've completed a dozen of these with no problems, with another 4 just started.

Also, the app for them is version 7.24, which has been there since July last year. This is the version that I've just used.

So perhaps your problem is caused by an update of something which deleted the mentioned lib and replaced it with a newer version.

ID: 51478 · Report as offensive     Reply Quote
Profile geophi
Volunteer moderator

Send message
Joined: 7 Aug 04
Posts: 1821
Credit: 36,393,036
RAC: 10
Message 51499 - Posted: 2 Mar 2015, 3:55:29 UTC

I see the same thing. All other apps run fine and have no unresolvable dependencies on CentOS/RHEL 6.6. But the one hadcm3s file you listed does have an unresolvable dependency. I guess it's a good sign that all the apps that have been built recently do not have this problem.
ID: 51499 · Report as offensive     Reply Quote

Questions and Answers : Unix/Linux : GLIBCXX_3.4.15

©2019 climateprediction.net