climateprediction.net home page
Cannot attach to climateprediction

Cannot attach to climateprediction

Questions and Answers : Getting started : Cannot attach to climateprediction
Message board moderation

To post messages, you must log in.

Previous · 1 · 2 · 3 · 4 · 5 · 6 . . . 7 · Next

AuthorMessage
Profile Ron Crouch
Avatar

Send message
Joined: 24 Feb 05
Posts: 45
Credit: 11,292,939
RAC: 0
Message 46375 - Posted: 7 Jun 2013, 21:00:50 UTC
Last modified: 7 Jun 2013, 21:30:57 UTC

Well someone came close to the workaround but not quite. This will work for Windows as well as Linux (new boxes). Open a terminal and navigate to your Boinc folder. On the command line enter the following: boinc --attach_project http://climateprediction.net (32 digit account key) then hit enter.

If it squawks at all then run boinc --detach_project http://climateprediction.net and try again.

Once it finishes downloading and starts to crunch you can do a Ctrl+Alt+C to exit boinc. Now you can start Boinc with the GUI. It will probably only download one work unit initially but it will fill up as time progresses.

Have fun!
ID: 46375 · Report as offensive     Reply Quote
Cadeus

Send message
Joined: 11 Aug 05
Posts: 2
Credit: 12,834,458
RAC: 1,219
Message 46385 - Posted: 9 Jun 2013, 3:34:10 UTC - in response to Message 46375.  

I could not connect using a GUI.

I had to use command line to connect. This has to be run in the boinc directory.

boinccmd --project_attach http://climateprediction.net strongKeyFromAccountInfo

There is a post on this thread that says use option "attach_project". Since the option is wrong it is misleading. Can someone else's post be corrected?

Thank you to everyone who is helping us connect.
ID: 46385 · Report as offensive     Reply Quote
Cadeus

Send message
Joined: 11 Aug 05
Posts: 2
Credit: 12,834,458
RAC: 1,219
Message 46386 - Posted: 9 Jun 2013, 3:35:02 UTC - in response to Message 46298.  
Last modified: 9 Jun 2013, 3:36:10 UTC

this post intentionally left blank.
ID: 46386 · Report as offensive     Reply Quote
Profile Ron Crouch
Avatar

Send message
Joined: 24 Feb 05
Posts: 45
Credit: 11,292,939
RAC: 0
Message 46387 - Posted: 9 Jun 2013, 4:41:25 UTC - in response to Message 46385.  
Last modified: 9 Jun 2013, 5:02:30 UTC

If you think I'm wrong then run boinc --help and see for yourself.

Oh yes, there is a difference between the commands boinc vs boinccmd. Boinc as a command starts the client while boinccmd will only give you what you need if a client is running, otherwise it has no client to connect to to gather any information.

The use of both can be found by running boinc --help or boinccmd --help.

I cannot state enough: YOU CANNOT ATTACH TO THE PROJECT AND DOWNLOAD ANY WORK UNITS USING THE BOINCCMD command. YOU CAN ONLY ATTACH AND DOWNLOAD NEW WORK USING THE BOINC command. IF YOU HAVE TRIED TO ATTACH TO THE PROJECT USING THE BOINCCMD YOU MUST DETACH FROM THE PROJECT AND ATTACH USING THE AFOREMENTIONED METHOD.

Thank you and have a nice day!
ID: 46387 · Report as offensive     Reply Quote
Profile Iain Inglis
Volunteer moderator

Send message
Joined: 16 Jan 10
Posts: 1019
Credit: 5,511,676
RAC: 4,392
Message 46388 - Posted: 9 Jun 2013, 8:59:21 UTC - in response to Message 46385.  

... There is a post on this thread that says use option "attach_project". Since the option is wrong it is misleading. Can someone else's post be corrected? ...
The original poster can edit a post for a short period of time. However, no-one else can do anything, including the moderators. The moderation facilities on this board are actually pretty crude - essentially 'hide post' and 'move post'.
ID: 46388 · Report as offensive     Reply Quote
Profile Ron Crouch
Avatar

Send message
Joined: 24 Feb 05
Posts: 45
Credit: 11,292,939
RAC: 0
Message 46393 - Posted: 9 Jun 2013, 16:01:43 UTC

Iain or Les or Maureen etc. I'm not sure if the private messaging is even working on this board. So.

It occured to me that when trying to attach to the project from the boinc gui that it asks for the users password, whereas when attaching from the command line one must enter the account key to attach. I wonder if inputting ones account key in the password field of the gui might work?

All I do know is that you can attach quite easily from the command line.

Cheers
ID: 46393 · Report as offensive     Reply Quote
Les Bayliss
Volunteer moderator

Send message
Joined: 5 Sep 04
Posts: 7233
Credit: 23,154,247
RAC: 341
Message 46395 - Posted: 9 Jun 2013, 20:47:11 UTC - in response to Message 46393.  

Yes, the PM system works here, provided that people have set that option in their prefs.

I prefer not to make command line attach the official way of getting to the project.
I'm waiting for the weekend to slowly crawl by so that I can talk to the project people about progress with fixing the Manager attach.



Backups: Here
ID: 46395 · Report as offensive     Reply Quote
Profile Byron Leigh Hatch @ team Carl Sagan
Avatar

Send message
Joined: 17 Aug 04
Posts: 289
Credit: 44,103,664
RAC: 151
Message 46396 - Posted: 9 Jun 2013, 23:37:14 UTC

Thanks Les, Iain, MikeMarsUK and all.
ID: 46396 · Report as offensive     Reply Quote
Manxie

Send message
Joined: 18 May 05
Posts: 9
Credit: 57,882
RAC: 0
Message 46397 - Posted: 10 Jun 2013, 11:24:49 UTC - in response to Message 46395.  

Hi Les

I've just had a new SSD hard drive fitted and copy & saved my BOINC file over from the old HD but now I do not get automatic start up when the PC is 1st started - can you help/advise on this please?

Thanks

Phil
ID: 46397 · Report as offensive     Reply Quote
Profile Dave Jackson
Volunteer moderator

Send message
Joined: 15 May 09
Posts: 2738
Credit: 3,388,112
RAC: 2,679
Message 46398 - Posted: 10 Jun 2013, 16:08:41 UTC - in response to Message 46397.  

Presumably you are using windows? If so then you still need to install BOINC as before and it should then start automatically?
ID: 46398 · Report as offensive     Reply Quote
Profile geophi
Volunteer moderator

Send message
Joined: 7 Aug 04
Posts: 1931
Credit: 41,487,636
RAC: 4,640
Message 46399 - Posted: 10 Jun 2013, 18:18:59 UTC - in response to Message 46397.  

I've just had a new SSD hard drive fitted and copy & saved my BOINC file over from the old HD but now I do not get automatic start up when the PC is 1st started - can you help/advise on this please?


You can also, in the Boinc Manager GUI, go to Tools -> Options and in the General tab, select "Run Manager at login".
ID: 46399 · Report as offensive     Reply Quote
Les Bayliss
Volunteer moderator

Send message
Joined: 5 Sep 04
Posts: 7233
Credit: 23,154,247
RAC: 341
Message 46400 - Posted: 10 Jun 2013, 22:26:58 UTC

Jonathan is still trying to get a script file to work, but the BOINC system is being difficult.


Backups: Here
ID: 46400 · Report as offensive     Reply Quote
Profile Byron Leigh Hatch @ team Carl Sagan
Avatar

Send message
Joined: 17 Aug 04
Posts: 289
Credit: 44,103,664
RAC: 151
Message 46401 - Posted: 10 Jun 2013, 23:43:52 UTC

Thanks for the update Les.
ID: 46401 · Report as offensive     Reply Quote
WB8ILI

Send message
Joined: 1 Sep 04
Posts: 139
Credit: 55,124,979
RAC: 13,734
Message 46408 - Posted: 12 Jun 2013, 11:48:57 UTC

As has been pointed out in other threads -

IF YOU ALREADY HAVE AN EXISTING climateprediction.net ACCOUNT -

1. Copy file account_climateprediction.net.xml from an exiting machine to your new machine.

2. Create a folder climateprediction.net in the Projects folder.

3. (Re)Start BOINC Manager.

Not sure if step 2 is necessary, but doing all three works.
ID: 46408 · Report as offensive     Reply Quote
old_user695141

Send message
Joined: 9 Feb 13
Posts: 2
Credit: 0
RAC: 0
Message 46433 - Posted: 17 Jun 2013, 11:38:05 UTC

How is this coming along? I am eager to start with this project.
ID: 46433 · Report as offensive     Reply Quote
Profile MikeMarsUK
Volunteer moderator
Avatar

Send message
Joined: 13 Jan 06
Posts: 1498
Credit: 15,613,038
RAC: 0
Message 46434 - Posted: 17 Jun 2013, 12:37:18 UTC - in response to Message 46433.  
Last modified: 17 Jun 2013, 12:39:32 UTC

How is this coming along? I am eager to start with this project.



Have you tried the command-line method of attaching mentioned earlier the thread? You open up a dos box / AKA command shell (type 'cmd' in the start button/run), and then do something like :

boinc --project_attach http://climateprediction.net strongKeyFromAccountInfo


I am not sure whether or not it is possible to attach with the above method if you do not already have a CPDN account.
I'm a volunteer and my views are my own.
News and Announcements and FAQ
ID: 46434 · Report as offensive     Reply Quote
Les Bayliss
Volunteer moderator

Send message
Joined: 5 Sep 04
Posts: 7233
Credit: 23,154,247
RAC: 341
Message 46438 - Posted: 17 Jun 2013, 20:08:15 UTC - in response to Message 46433.  

Mr Brown

Your computer has been attached since February.
If you haven't had any work in that time, then you have a different problem.



Backups: Here
ID: 46438 · Report as offensive     Reply Quote
old_user695141

Send message
Joined: 9 Feb 13
Posts: 2
Credit: 0
RAC: 0
Message 46443 - Posted: 18 Jun 2013, 11:26:36 UTC

Well I did attach it in Feb. And I did get work I think, but I aborted it because it would of been to large to handle on my old computer. Now I have a new computer and think I could run the units.
ID: 46443 · Report as offensive     Reply Quote
Profile MikeMarsUK
Volunteer moderator
Avatar

Send message
Joined: 13 Jan 06
Posts: 1498
Credit: 15,613,038
RAC: 0
Message 46445 - Posted: 18 Jun 2013, 14:06:02 UTC


Do you still have access to that old computer? (or at least, the data on it's disk). If so, then following:
http://climateapps2.oerc.ox.ac.uk/cpdnboinc/forum_thread.php?id=7558&nowrap=true#46408
may help.


I'm a volunteer and my views are my own.
News and Announcements and FAQ
ID: 46445 · Report as offensive     Reply Quote
Profile clif9710

Send message
Joined: 18 Feb 11
Posts: 33
Credit: 9,849,374
RAC: 1,014
Message 46455 - Posted: 19 Jun 2013, 5:52:52 UTC - in response to Message 46438.  
Last modified: 19 Jun 2013, 5:58:32 UTC

Les:

I have had four machines running. As explained in another posting, I removed one of them from the project and when it turned out I would not be giving the machine away, I have been unable to reconnect to use it on the project as I did before. The problem still remains today after a few weeks of trying. "Error has occurred - check the event log for details".

I believe I have to copy an XML file?

Will the regular way of connecting be restored at some point? I can be infinitely patient, for months, years? I just need a ray of hope.
ID: 46455 · Report as offensive     Reply Quote
Previous · 1 · 2 · 3 · 4 · 5 · 6 . . . 7 · Next

Questions and Answers : Getting started : Cannot attach to climateprediction

©2020 climateprediction.net