climateprediction.net home page
platform 'i586-mandriva-linux-gnu' not found

platform 'i586-mandriva-linux-gnu' not found

Questions and Answers : Unix/Linux : platform 'i586-mandriva-linux-gnu' not found
Message board moderation

To post messages, you must log in.

AuthorMessage
Profile Dave Jackson
Volunteer moderator

Send message
Joined: 15 May 09
Posts: 3135
Credit: 8,506,890
RAC: 18,656
Message 36928 - Posted: 15 May 2009, 9:01:51 UTC

I have used boinc software with older versions of mandriva without problems. I now get the following message. Is there a way to tell the boinc software something different, possible renaming something in /etc?
ID: 36928 · Report as offensive     Reply Quote
Profile old_user60427
Avatar

Send message
Joined: 4 Mar 05
Posts: 24
Credit: 243,647
RAC: 0
Message 36941 - Posted: 17 May 2009, 7:56:56 UTC - in response to Message 36928.  

The error message reminds me of this sort of init-script to start boinc (/etc/init.d/boinc): it is looking for boinc manager with a certain name.

The issue is (if my assumption that the error comes from the script is right) that your boinc-manager has a different name than the /etc/init.d/boinc script is looking for.

Go to yr boinc directory and try to start boinc manually -- don't forget that you may need to logon as the user all the boinc software is installed under.
ID: 36941 · Report as offensive     Reply Quote
Les Bayliss
Volunteer moderator

Send message
Joined: 5 Sep 04
Posts: 7474
Credit: 23,547,955
RAC: 3,044
Message 36942 - Posted: 17 May 2009, 8:44:26 UTC

There is a thread 2 posts before this one, with a similar title and about the same problem.


Backups: Here
ID: 36942 · Report as offensive     Reply Quote
Profile old_user197041
Avatar

Send message
Joined: 27 Aug 06
Posts: 26
Credit: 162,685
RAC: 0
Message 36943 - Posted: 17 May 2009, 15:41:07 UTC
Last modified: 17 May 2009, 15:42:40 UTC

Grrrr. Stupid Mandriva packagers.

They're compiling it wrong. So the server is saying "Hey, I don't have a app for that platform. Now if you were asking for i686-pc-linux-gnu, we'd be all set."

Here's what I'd do if I were you. I'd run down all the work on your machine, if there is any. Uninstall BOINC using the package manager. Grab BOINC from here. Follow the instructions here to install.

And if you really want to help, file a bug against the package. Point the packager to this Wiki page and tell them to make note of the configure command.


I believe there are other ways around this (using the anonymous platform method) but that seems like a pain to me.
Kathryn :o)
The BOINC FAQ Service
The Unofficial BOINC Wiki
The Trac System
More BOINC information than you can shake a stick of RAM at.
ID: 36943 · Report as offensive     Reply Quote
Profile Skip Da Shu
Avatar

Send message
Joined: 31 Aug 04
Posts: 42
Credit: 13,584,908
RAC: 0
Message 38661 - Posted: 9 Jan 2010, 20:42:00 UTC - in response to Message 36943.  
Last modified: 9 Jan 2010, 20:43:48 UTC

Grrrr. Stupid Mandriva packagers.

They\'re compiling it wrong. So the server is saying \"Hey, I don\'t have a app for that platform. Now if you were asking for i686-pc-linux-gnu, we\'d be all set.\"

Here\'s what I\'d do if I were you. I\'d run down all the work on your machine, if there is any. Uninstall BOINC using the package manager. Grab BOINC from here. Follow the instructions here to install.

And if you really want to help, file a bug against the package. Point the packager to this Wiki page and tell them to make note of the configure command.


I believe there are other ways around this (using the anonymous platform method) but that seems like a pain to me.


I CAN NOT believe this problem STILL exists... somebody handed me a Mandriva machine (2010) and I was installing BOINC for them... after getting around the gui_rpc_auth.cfg problem where the manager will not attach to the client I\'d hoped I was done... attach any project... and I get this crap... 7 months later. They need to take a look at the Debian package. It just works.
ID: 38661 · Report as offensive     Reply Quote

Questions and Answers : Unix/Linux : platform 'i586-mandriva-linux-gnu' not found

©2021 climateprediction.net