climateprediction.net home page
problem with 64 bit app on Ubuntu dapper

problem with 64 bit app on Ubuntu dapper

Questions and Answers : Unix/Linux : problem with 64 bit app on Ubuntu dapper
Message board moderation

To post messages, you must log in.

AuthorMessage
old_user486927

Send message
Joined: 11 Dec 07
Posts: 2
Credit: 261,991
RAC: 0
Message 32329 - Posted: 24 Jan 2008, 12:51:37 UTC

Hi folks i have it running Ok on Gutsy, but on Dapper I run into problems like this one:

http://climateapps2.oucs.ox.ac.uk/cpdnboinc/result.php?resultid=7207094

any ideas?

thanks

Bernhard
ID: 32329 · Report as offensive     Reply Quote
Les Bayliss
Volunteer moderator

Send message
Joined: 5 Sep 04
Posts: 7161
Credit: 22,686,550
RAC: 10,671
Message 32339 - Posted: 24 Jan 2008, 20:00:03 UTC


No Linux people have showed up to answer this, so my best guess is it\'s a permissions problem.

Installed as Admin, and trying to run as normal user?
Something to do with type of install (service / single user / muti-user)?

ID: 32339 · Report as offensive     Reply Quote
Profile astroWX
Volunteer moderator

Send message
Joined: 5 Aug 04
Posts: 1496
Credit: 94,837,856
RAC: 12,400
Message 32340 - Posted: 24 Jan 2008, 21:24:50 UTC
Last modified: 24 Jan 2008, 21:42:14 UTC

What Messages are posted in the Manager when the problem occurs? Anything about libraries?

Not sure this works yet (I use 32-bit boinc Clients on my 64-bit boxes):
/projects/climateprediction.net/hadsm3_5.10_x86_64-pc-linux-gnu)


Edit: Two days ago, Kubuntu 7.10 was installed on one of my boxes and fed a CPDNboinc folder from openSuSE. It refused to execute Client or Manager from the \"straight\" folder though all permissions were okay. Unzipped the other folder and tried that -- with the same result.

I didn\'t allow Kubuntu to remain on the machine long enough to dig very deep into the issue, so I can\'t provide advice from personal experience. I suspected library issues, or that I was trying to run from the Desktop, but Kubuntu gave me no hints to work with.
"We have met the enemy and he is us." -- Pogo
Greetings from coastal Washington state, the scenic US Pacific Northwest.
ID: 32340 · Report as offensive     Reply Quote
Profile MikeMarsUK
Volunteer moderator
Avatar

Send message
Joined: 13 Jan 06
Posts: 1498
Credit: 15,613,038
RAC: 0
Message 32344 - Posted: 25 Jan 2008, 8:26:18 UTC - in response to Message 32342.  
Last modified: 25 Jan 2008, 8:36:44 UTC

\"brohrer\" wrote:
...

actually the 32bit libraries were missing. the problem is now that dapper has glibc 2.35 and 2.4 is needed. I\'ll have to wait for [a later version of Ubuntu]



The HadSM3mH model (currently in beta testing) has been built with glibc 2.3 support, so you need not wait for the specific Ubuntu version you mention (which isn\'t on the roadmap for some reason).


I'm a volunteer and my views are my own.
News and Announcements and FAQ
ID: 32344 · Report as offensive     Reply Quote

Questions and Answers : Unix/Linux : problem with 64 bit app on Ubuntu dapper

©2020 climateprediction.net