climateprediction.net home page
Bad Copy of BOINC DL Hangs Around Like Dracula

Bad Copy of BOINC DL Hangs Around Like Dracula

Questions and Answers : Unix/Linux : Bad Copy of BOINC DL Hangs Around Like Dracula
Message board moderation

To post messages, you must log in.

AuthorMessage
Profile old_user27607

Send message
Joined: 28 Oct 04
Posts: 64
Credit: 34,444,555
RAC: 0
Message 28691 - Posted: 14 May 2007, 16:41:49 UTC

I really managed to screw up on this one. I am running Suse Linux 10, up to date, and was successfully running BOINC 5.8.11.

But the system was resetting from an unknown cause, so I decided to DL the latest BOINC, 5.8.17. The DL got stopped short of the end for some reason, but I continued to the end.

Now comes the Undead part. The .17 DL was bad, and could not be erased. Eventually I deleted and rebooted, did a full good DL (AFAICT), reinstalled. Starting up .17 creates the following error message:
./boinc: /lib/tls/libc.so.6: version `GLIBC_2.4\' not found (required by ./boinc)

This may be a Linux version limitation. Is it possible to get an older version of BOINC that will run on SL10? Or am I forced to upgrade SL10, which interferes with running Parallels?
ID: 28691 · Report as offensive     Reply Quote
Profile Thyme Lawn
Volunteer moderator

Send message
Joined: 5 Aug 04
Posts: 1278
Credit: 15,779,438
RAC: 415
Message 28693 - Posted: 14 May 2007, 17:37:53 UTC

5.8.17 was built with a newer compiler version and uses versions of glibc and stdc++ that might not be available on some older distributions.

You should be able to run 5.8.16 - here are the download links:

5.8.16 release version

5.8.16 debug version
"The ultimate test of a moral society is the kind of world that it leaves to its children." - Dietrich Bonhoeffer
ID: 28693 · Report as offensive     Reply Quote
Profile old_user27607

Send message
Joined: 28 Oct 04
Posts: 64
Credit: 34,444,555
RAC: 0
Message 28695 - Posted: 14 May 2007, 18:00:33 UTC - in response to Message 28693.  

5.8.17 was built with a newer compiler version and uses versions of glibc and stdc++ that might not be available on some older distributions.

You should be able to run 5.8.16 - here are the download links:

5.8.16 release version

5.8.16 debug version


Great response, instant fix, dual core system now running again.
Thanks!

BillN

ID: 28695 · Report as offensive     Reply Quote

Questions and Answers : Unix/Linux : Bad Copy of BOINC DL Hangs Around Like Dracula

©2020 climateprediction.net