climateprediction.net home page
Computer shutdown --> loose all work

Computer shutdown --> loose all work

Questions and Answers : Windows : Computer shutdown --> loose all work
Message board moderation

To post messages, you must log in.

AuthorMessage
Profile xmal

Send message
Joined: 5 Aug 04
Posts: 10
Credit: 1,636,536
RAC: 0
Message 475 - Posted: 8 Aug 2004, 22:08:08 UTC

Hello, I don\'t known why but after shuting down my computer and restar it, CP wasn\'t anymore in the work area and Boinc download another WU and restart the work from 0.

ID: 475 · Report as offensive     Reply Quote
belgix

Send message
Joined: 5 Aug 04
Posts: 85
Credit: 2,924,043
RAC: 0
Message 484 - Posted: 9 Aug 2004, 2:07:52 UTC
Last modified: 9 Aug 2004, 2:15:33 UTC

Sounds like BOINC might not have closed the model down cleanly. I don't know if this bug were fixed in BOINC v4.02 but this had happened to me with v3.20.
ID: 484 · Report as offensive     Reply Quote
old_user194

Send message
Joined: 5 Aug 04
Posts: 63
Credit: 21,399,117
RAC: 0
Message 496 - Posted: 9 Aug 2004, 6:39:02 UTC

I have possibly the opposite problem - I currently appear to have 2 cpdn projects (but only one WU), each with a resource share of 50%. Last night I ran defrag (XP). This didn't just slow down the beta but instead killed it off completely, something that hasn't happened before, either in 'classic' cpdn or in the alpha. Upon restarting I had the two projects, one with my account and one blank. This is a (slight) annoyance as one of them, presumably the phantom one, keeps trying to connect to Oxford (or somewhere) and keeps failing - currently deferring for 1 wk, 6 days, ... The other, presumably non-phantom, project is cruising along nicely at 3.5 s/TS.

Cheers,

PeterV.
ID: 496 · Report as offensive     Reply Quote
Profile Keck_Komputers
Avatar

Send message
Joined: 5 Aug 04
Posts: 426
Credit: 2,217,550
RAC: 2,779
Message 503 - Posted: 9 Aug 2004, 7:43:58 UTC

@belgix & xmal
The fix is not in yet. They are planning on going to a 2 file rotation for the client_state.xml file which should solve alot of the lost workunit issues at restarts and crashes.

@verstapp
Your problem is most likely an extra space in the URL when you attached. Exit the client and restart it a couple of times. If that does not clear it up the fix is kinda ugly with these long workunits so brace yourself. Detach from the offending project (all instances). Exit the BOINC client. Delete all account...xml files and project directories belonging to the offending project. Restart the BOINC client and reattach to the problem project.

Be careful not to include any extra spaces in the URL or authenticator. Windows will sometimes add a trailing space when you cut and paste so beware.
<br>John Keck
BOINCing since 2002/12/08
ID: 503 · Report as offensive     Reply Quote
old_user10

Send message
Joined: 5 Aug 04
Posts: 55
Credit: 87,392
RAC: 0
Message 508 - Posted: 9 Aug 2004, 8:34:28 UTC

I just had the same think but found my mistake. When I installed the 4.02 client, I installed to a different directory but didn't correct the shortcut I'd added to my startup folder. When I rebooted, it started version 3.18 which failed the 'master file fetch' and showed no workunit. I exited it, corrected the link and started up 4.02. It's runing again now with no lost work.

phew...
ID: 508 · Report as offensive     Reply Quote
Profile old_user504
Avatar

Send message
Joined: 7 Aug 04
Posts: 33
Credit: 215,841
RAC: 0
Message 516 - Posted: 9 Aug 2004, 11:40:51 UTC - in response to Message 484.  

I havn't had this problem, I checked BOINC's version and I have 4.03.
ID: 516 · Report as offensive     Reply Quote
Profile xmal

Send message
Joined: 5 Aug 04
Posts: 10
Credit: 1,636,536
RAC: 0
Message 558 - Posted: 9 Aug 2004, 18:04:54 UTC - in response to Message 508.  

&gt; I just had the same think but found my mistake. When I installed the 4.02
&gt; client, I installed to a different directory but didn't correct the shortcut
&gt; I'd added to my startup folder. When I rebooted, it started version 3.18 which
&gt; failed the 'master file fetch' and showed no workunit. I exited it, corrected
&gt; the link and started up 4.02. It's runing again now with no lost work.

GREAAAAAT! I wasn't thinking I could be so... hem... stupid! Of course, bad link.... B-)

Well, that was the problem. But, now, Boinc has downloaded another WU and is working on it, what should I do ? the first WU will restart at next reboot and then the other when the first will be ended ? Or what ?

Anyway, thanx to all for your help, it's great!

ID: 558 · Report as offensive     Reply Quote

Questions and Answers : Windows : Computer shutdown --> loose all work

©2019 climateprediction.net